Re: [PATCH v3 03/11] mm/page_table_check: Batch-check pmds/puds just like ptes
From: Ryan Roberts
Date: Wed Mar 26 2025 - 10:58:01 EST
On 26/03/2025 10:48, Pasha Tatashin wrote:
>> -void __page_table_check_pud_set(struct mm_struct *mm, pud_t *pudp, pud_t pud)
>> +void __page_table_check_puds_set(struct mm_struct *mm, pud_t *pudp, pud_t pud,
>> + unsigned int nr)
>> {
>> + unsigned int i;
>> + unsigned long stride = PUD_SIZE >> PAGE_SHIFT;
>
> nit: please order declarations from longest to shortest, it usually
> helps with readability. (here and in pmd)
Noted, I'll fix this.
>
> Reviewed-by: Pasha Tatashin <pasha.tatashin@xxxxxxxxxx>
Thanks!
>
> Pasha