[PATCH 14/14] bugs/core: Reorganize fields in the first line of WARNING output, add ->comm[] output
From: Ingo Molnar
Date: Thu Mar 27 2025 - 06:33:02 EST
With the introduction of the condition string as part of the 'file'
string output of kernel warnings, the first line has become a bit
harder to read:
WARNING: CPU: 0 PID: 0 at [ptr == 0 && 1] kernel/sched/core.c:8511 sched_init+0x20/0x410
Re-order the fields by importance (higher to lower), make the 'at' meaningful
again, and add '->comm[]' output which is often more valuable than a PID.
Also, remove the 'PID' prefix - in combination with comm it's clear what it is.
These changes make the output only slightly longer:
WARNING: [ptr == 0 && 1] kernel/sched/core.c:8511 at sched_init+0x20/0x410 CPU#0: swapper/0
While adding more information and making it better organized.
Signed-off-by: Ingo Molnar <mingo@xxxxxxxxxx>
Cc: <linux-arch@xxxxxxxxxxxxxxx>
---
kernel/panic.c | 16 +++++++++-------
1 file changed, 9 insertions(+), 7 deletions(-)
diff --git a/kernel/panic.c b/kernel/panic.c
index d8635d5cecb2..e57a61faa05f 100644
--- a/kernel/panic.c
+++ b/kernel/panic.c
@@ -724,13 +724,15 @@ void __warn(const char *file, int line, void *caller, unsigned taint,
disable_trace_on_warning();
- if (file)
- pr_warn("WARNING: CPU: %d PID: %d at %s:%d %pS\n",
- raw_smp_processor_id(), current->pid, file, line,
- caller);
- else
- pr_warn("WARNING: CPU: %d PID: %d at %pS\n",
- raw_smp_processor_id(), current->pid, caller);
+ if (file) {
+ pr_warn("WARNING: %s:%d at %pS, CPU#%d: %s/%d\n",
+ file, line, caller,
+ raw_smp_processor_id(), current->comm, current->pid);
+ } else {
+ pr_warn("WARNING: at %pS, CPU#%d: %s/%d\n",
+ caller,
+ raw_smp_processor_id(), current->comm, current->pid);
+ }
#pragma GCC diagnostic push
#ifndef __clang__
--
2.45.2