[PATCH 28/41] x86/alternatives: Rename 'try_get_desc()' to 'try_get_tp_array()'
From: Ingo Molnar
Date: Thu Mar 27 2025 - 17:03:37 EST
This better reflects what the underlying code is doing,
there's no 'descriptor' indirection anymore.
Signed-off-by: Ingo Molnar <mingo@xxxxxxxxxx>
---
arch/x86/kernel/alternative.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/arch/x86/kernel/alternative.c b/arch/x86/kernel/alternative.c
index 3baef1827f3c..4b5ab9002e07 100644
--- a/arch/x86/kernel/alternative.c
+++ b/arch/x86/kernel/alternative.c
@@ -2476,7 +2476,7 @@ static struct text_poke_int3_array {
static DEFINE_PER_CPU(atomic_t, int3_refs);
static __always_inline
-struct text_poke_int3_array *try_get_desc(void)
+struct text_poke_int3_array *try_get_tp_array(void)
{
atomic_t *refs = this_cpu_ptr(&int3_refs);
@@ -2530,7 +2530,7 @@ noinstr int text_poke_int3_handler(struct pt_regs *regs)
*/
smp_rmb();
- desc = try_get_desc();
+ desc = try_get_tp_array();
if (!desc)
return 0;
@@ -2627,7 +2627,7 @@ static void text_poke_int3_batch(struct text_poke_int3_loc *tp, unsigned int nr_
WARN_ON_ONCE(nr_entries != tp_array.nr_entries);
/*
- * Corresponds to the implicit memory barrier in try_get_desc() to
+ * Corresponds to the implicit memory barrier in try_get_tp_array() to
* ensure reading a non-zero refcount provides up to date tp_array data.
*/
for_each_possible_cpu(i)
--
2.45.2