[PATCH 29/41] x86/alternatives: Rename 'put_desc()' to 'put_tp_array()'

From: Ingo Molnar
Date: Thu Mar 27 2025 - 17:04:19 EST


Just like with try_get_tp_array(), this name better reflects
what the underlying code is doing, there's no 'descriptor'
indirection anymore.

Signed-off-by: Ingo Molnar <mingo@xxxxxxxxxx>
---
arch/x86/kernel/alternative.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/x86/kernel/alternative.c b/arch/x86/kernel/alternative.c
index 4b5ab9002e07..0b11f53d6e6d 100644
--- a/arch/x86/kernel/alternative.c
+++ b/arch/x86/kernel/alternative.c
@@ -2486,7 +2486,7 @@ struct text_poke_int3_array *try_get_tp_array(void)
return &tp_array;
}

-static __always_inline void put_desc(void)
+static __always_inline void put_tp_array(void)
{
atomic_t *refs = this_cpu_ptr(&int3_refs);

@@ -2590,7 +2590,7 @@ noinstr int text_poke_int3_handler(struct pt_regs *regs)
ret = 1;

out_put:
- put_desc();
+ put_tp_array();
return ret;
}

--
2.45.2