Re: [PATCH 1/3] usb: renesas_usbhs: Correct function reference in comment

From: Lad, Prabhakar
Date: Fri Mar 28 2025 - 04:32:41 EST


Hi Kuninori san,

Thank you for the review.

On Fri, Mar 28, 2025 at 12:09 AM Kuninori Morimoto
<kuninori.morimoto.gx@xxxxxxxxxxx> wrote:
>
>
> Hi Prabhakar
>
> Thank you for your patch
>
> > From: Lad Prabhakar <prabhakar.mahadev-lad.rj@xxxxxxxxxxxxxx>
> >
> > Update the comment to reference `usbhs_mod_probe` instead of
> > `usbhs_mod_init`, as `usbhs_mod_probe` is the correct function
> > used in this context.
> >
> > Signed-off-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@xxxxxxxxxxxxxx>
> > ---
> > drivers/usb/renesas_usbhs/common.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/drivers/usb/renesas_usbhs/common.c b/drivers/usb/renesas_usbhs/common.c
> > index 4b35ef216125..15ef246a1245 100644
> > --- a/drivers/usb/renesas_usbhs/common.c
> > +++ b/drivers/usb/renesas_usbhs/common.c
> > @@ -698,7 +698,7 @@ static int usbhs_probe(struct platform_device *pdev)
> > if (ret < 0)
> > goto probe_end_fifo_exit;
> >
> > - /* dev_set_drvdata should be called after usbhs_mod_init */
> > + /* dev_set_drvdata should be called after usbhs_mod_probe */
> > platform_set_drvdata(pdev, priv);
>
> If you want to care about context, it seems we want to care "dev_set_drvdata"
> and "platform_set_drvdata" too :)
> And, it is easy to understand that it indicates function if it has ().
> like below
>
> - /* dev_set_drvdata should be called after usbhs_mod_init */
> + /* platform_set_drvdata() should be called after usbhs_mod_probe() */
> platform_set_drvdata(pdev, priv);
>
Ok, I'll update it as above in v2.

Cheers,
Prabhakar