Re: [PATCH v3 07/12] media: imx8mq-mipi-csi2: Add imx8mq_plat_data for different compatible strings
From: Daniel Baluta
Date: Fri Mar 28 2025 - 04:34:30 EST
On Mon, Feb 10, 2025 at 11:02 PM Frank Li <Frank.Li@xxxxxxx> wrote:
>
> From: "Guoniu.zhou" <guoniu.zhou@xxxxxxx>
>
> Introduce `imx8mq_plat_data` along with enable/disable callback operations
> to facilitate support for new chips. No functional changes.
>
> Signed-off-by: Guoniu.zhou <guoniu.zhou@xxxxxxx>
> Signed-off-by: Frank Li <Frank.Li@xxxxxxx>
> ---
> Change from v2 to v3
> - none
> change from v1 to v2
> - remove internal review tags
> ---
> drivers/media/platform/nxp/imx8mq-mipi-csi2.c | 60 ++++++++++++++++++++-------
> 1 file changed, 46 insertions(+), 14 deletions(-)
>
> diff --git a/drivers/media/platform/nxp/imx8mq-mipi-csi2.c b/drivers/media/platform/nxp/imx8mq-mipi-csi2.c
> index 1f2657cf6e824..b5eae56d92f49 100644
> --- a/drivers/media/platform/nxp/imx8mq-mipi-csi2.c
> +++ b/drivers/media/platform/nxp/imx8mq-mipi-csi2.c
> @@ -62,6 +62,8 @@
> #define CSI2RX_CFG_VID_P_FIFO_SEND_LEVEL 0x188
> #define CSI2RX_CFG_DISABLE_PAYLOAD_1 0x130
>
> +struct csi_state;
> +
> enum {
> ST_POWERED = 1,
> ST_STREAMING = 2,
> @@ -83,11 +85,11 @@ static const char * const imx8mq_mipi_csi_clk_id[CSI2_NUM_CLKS] = {
>
> #define CSI2_NUM_CLKS ARRAY_SIZE(imx8mq_mipi_csi_clk_id)
>
> -#define GPR_CSI2_1_RX_ENABLE BIT(13)
> -#define GPR_CSI2_1_VID_INTFC_ENB BIT(12)
> -#define GPR_CSI2_1_HSEL BIT(10)
> -#define GPR_CSI2_1_CONT_CLK_MODE BIT(8)
> -#define GPR_CSI2_1_S_PRG_RXHS_SETTLE(x) (((x) & 0x3f) << 2)
> +struct imx8mq_plat_data {
> + const char *name;
> + int (*enable)(struct csi_state *state, u32 hs_settle);
> + void (*disable)(struct csi_state *state);
> +};
>
> /*
> * The send level configures the number of entries that must accumulate in
> @@ -106,6 +108,7 @@ static const char * const imx8mq_mipi_csi_clk_id[CSI2_NUM_CLKS] = {
>
> struct csi_state {
> struct device *dev;
> + const struct imx8mq_plat_data *pdata;
> void __iomem *regs;
> struct clk_bulk_data clks[CSI2_NUM_CLKS];
> struct reset_control *rst;
> @@ -137,6 +140,35 @@ struct csi2_pix_format {
> u8 width;
> };
>
> +/* -----------------------------------------------------------------------------
I would drop this line. It doesn't make code easier to read.
> + * i.MX8MQ GPR
> + */
Just say: /* i.MX8MQ GPR */
This pattern happens in a lot of places.