[PATCH 21/49] x86/alternatives: Use non-inverted logic instead of 'tp_order_fail()'
From: Ingo Molnar
Date: Fri Mar 28 2025 - 09:32:52 EST
tp_order_fail() uses inverted logic: it returns true in case something
is false, which is only a plus at the IOCCC.
Instead rename it to regular parity as 'text_poke_addr_ordered()',
and adjust the code accordingly.
Also add a comment explaining how the address ordering should be
understood.
No change in functionality intended.
Signed-off-by: Ingo Molnar <mingo@xxxxxxxxxx>
---
arch/x86/kernel/alternative.c | 20 +++++++++++++-------
1 file changed, 13 insertions(+), 7 deletions(-)
diff --git a/arch/x86/kernel/alternative.c b/arch/x86/kernel/alternative.c
index 5fe54f3c6211..66778dac257f 100644
--- a/arch/x86/kernel/alternative.c
+++ b/arch/x86/kernel/alternative.c
@@ -2843,28 +2843,34 @@ static void text_poke_int3_loc_init(struct smp_text_poke_loc *tp, void *addr,
* We hard rely on the tp_vec being ordered; ensure this is so by flushing
* early if needed.
*/
-static bool tp_order_fail(void *addr)
+static bool text_poke_addr_ordered(void *addr)
{
struct smp_text_poke_loc *tp;
if (!tp_vec_nr)
- return false;
+ return true;
if (!addr) /* force */
- return true;
+ return false;
- tp = &tp_vec[tp_vec_nr - 1];
+ /*
+ * If the last current entry's address is higher than the
+ * new entry's address we'd like to add, then ordering
+ * is violated and we must first flush all pending patching
+ * requests:
+ */
+ tp = &tp_vec[tp_vec_nr-1];
if ((unsigned long)text_poke_addr(tp) > (unsigned long)addr)
- return true;
+ return false;
- return false;
+ return true;
}
static void smp_text_poke_batch_flush(void *addr)
{
lockdep_assert_held(&text_mutex);
- if (tp_vec_nr == TP_VEC_MAX || tp_order_fail(addr)) {
+ if (tp_vec_nr == TP_VEC_MAX || !text_poke_addr_ordered(addr)) {
smp_text_poke_batch_process(tp_vec, tp_vec_nr);
tp_vec_nr = 0;
}
--
2.45.2