[PATCH 27/49] x86/alternatives: Rename 'try_get_desc()' to 'try_get_text_poke_array()'
From: Ingo Molnar
Date: Fri Mar 28 2025 - 09:34:14 EST
This better reflects what the underlying code is doing,
there's no 'descriptor' indirection anymore.
Signed-off-by: Ingo Molnar <mingo@xxxxxxxxxx>
---
arch/x86/kernel/alternative.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/arch/x86/kernel/alternative.c b/arch/x86/kernel/alternative.c
index 82808deb1501..26bb2a731208 100644
--- a/arch/x86/kernel/alternative.c
+++ b/arch/x86/kernel/alternative.c
@@ -2476,7 +2476,7 @@ static struct smp_text_poke_array {
static DEFINE_PER_CPU(atomic_t, int3_refs);
static __always_inline
-struct smp_text_poke_array *try_get_desc(void)
+struct smp_text_poke_array *try_get_text_poke_array(void)
{
atomic_t *refs = this_cpu_ptr(&int3_refs);
@@ -2530,7 +2530,7 @@ noinstr int smp_text_poke_int3_trap_handler(struct pt_regs *regs)
*/
smp_rmb();
- desc = try_get_desc();
+ desc = try_get_text_poke_array();
if (!desc)
return 0;
@@ -2627,7 +2627,7 @@ static void smp_text_poke_batch_process(struct smp_text_poke_loc *tp, unsigned i
WARN_ON_ONCE(nr_entries != text_poke_array.nr_entries);
/*
- * Corresponds to the implicit memory barrier in try_get_desc() to
+ * Corresponds to the implicit memory barrier in try_get_text_poke_array() to
* ensure reading a non-zero refcount provides up to date text_poke_array data.
*/
for_each_possible_cpu(i)
--
2.45.2