Re: [PATCH v7] ufs: core: Add WB buffer resize support
From: Huan Tang
Date: Wed Apr 02 2025 - 04:08:30 EST
> The description of the attribute contradicts the name of the attribute.
> Wouldn't wb_resize_enable be a better name for this attribute?
> Additionally, that name will be easier to recognize for anyone who is
> familiar with the UFS 4.1 standard.
>
> To be consistent with other sysfs attributes, the names of the verbs
> should be changed from upper case to lower case and "Others - Reserved"
> should be left out. This comment also applies to the other attributes.
>
> > +static const char *ufs_wb_resize_hint_to_string(enum wb_resize_hint hint)
> > +{
> > + switch (hint) {
> > + case WB_RESIZE_HINT_KEEP: return "KEEP";
> > + case WB_RESIZE_HINT_DECREASE: return "DECREASE";
> > + case WB_RESIZE_HINT_INCREASE: return "INCREASE";
> > + default: return "UNKNOWN";
> > + }
> > +}
> The formatting of the above switch/case statement is not compliant with
> the Linux kernel coding style.
Bart sir,
Thank you for your reply .
I have modified it according to your comments, as follows:
https://lore.kernel.org/all/20250402075710.224-1-tanghuan@xxxxxxxx/
Thank you for your patience, please help review again.
Thanks
Huan