Re: [PATCH 37/49] x86/alternatives: Move text_poke_array completion from smp_text_poke_batch_finish() and smp_text_poke_batch_flush() to smp_text_poke_batch_process()
From: Ingo Molnar
Date: Thu Apr 03 2025 - 09:39:36 EST
* Nikolay Borisov <nik.borisov@xxxxxxxx> wrote:
>
>
> On 28.03.25 г. 15:26 ч., Ingo Molnar wrote:
> > Simplifies the code and improves code generation a bit:
> >
> > text data bss dec hex filename
> > 14769 1017 4112 19898 4dba alternative.o.before
> > 14742 1017 4112 19871 4d9f alternative.o.after
> >
> > Signed-off-by: Ingo Molnar <mingo@xxxxxxxxxx>
> > ---
> > arch/x86/kernel/alternative.c | 11 +++++------
> > 1 file changed, 5 insertions(+), 6 deletions(-)
> >
> > diff --git a/arch/x86/kernel/alternative.c b/arch/x86/kernel/alternative.c
> > index 1df8fac6740d..5293929488f0 100644
> > --- a/arch/x86/kernel/alternative.c
> > +++ b/arch/x86/kernel/alternative.c
> > @@ -2750,6 +2750,9 @@ static void smp_text_poke_batch_process(void)
> > if (unlikely(!atomic_dec_and_test(refs)))
> > atomic_cond_read_acquire(refs, !VAL);
> > }
> > +
> > + /* They are all completed: */
> > + text_poke_array.nr_entries = 0;
> > }
> > static void __smp_text_poke_batch_add(void *addr, const void *opcode, size_t len, const void *emulate)
> > @@ -2857,20 +2860,16 @@ static bool text_poke_addr_ordered(void *addr)
> > void smp_text_poke_batch_finish(void)
> > {
> > - if (text_poke_array.nr_entries) {
> > + if (text_poke_array.nr_entries)
> > smp_text_poke_batch_process();
> > - text_poke_array.nr_entries = 0;
> > - }
> > }
>
> This function becomes trivial, why not simply move the check into
> smp_text_poke_batch_process and rename it to smp_text_poke_batch_finish ?
Yeah, that's pretty much what happens in patch #47:
x86/alternatives: Remove 'smp_text_poke_batch_flush()'
Thanks,
Ingo