Re: [PATCH v5 11/21] RISC-V: perf: Restructure the SBI PMU code
From: Will Deacon
Date: Fri Apr 04 2025 - 09:49:57 EST
On Thu, Mar 27, 2025 at 12:35:52PM -0700, Atish Patra wrote:
> With Ssccfg/Smcdeleg, we no longer need SBI PMU extension to program/
> access hpmcounter/events. However, we do need it for firmware counters.
> Rename the driver and its related code to represent generic name
> that will handle both sbi and ISA mechanism for hpmcounter related
> operations. Take this opportunity to update the Kconfig names to
> match the new driver name closely.
>
> No functional change intended.
>
> Reviewed-by: Clément Léger <cleger@xxxxxxxxxxxx>
> Signed-off-by: Atish Patra <atishp@xxxxxxxxxxxx>
> ---
> MAINTAINERS | 4 +-
> arch/riscv/include/asm/kvm_vcpu_pmu.h | 4 +-
> arch/riscv/include/asm/kvm_vcpu_sbi.h | 2 +-
> arch/riscv/kvm/Makefile | 4 +-
> arch/riscv/kvm/vcpu_sbi.c | 2 +-
> drivers/perf/Kconfig | 16 +-
> drivers/perf/Makefile | 4 +-
> drivers/perf/{riscv_pmu.c => riscv_pmu_common.c} | 0
> drivers/perf/{riscv_pmu_sbi.c => riscv_pmu_dev.c} | 214 +++++++++++++---------
I'm still against this renaming churn. It sucks for backporting and
you're also changing the name of the driver, which could be used by
scripts in userspace (e.g. module listings, udev rules, cmdline options)
Will