Re: [PATCH linux-next 5/5] phy: rockchip: phy-rockchip-typec: Use dev_err_probe()
From: Sebastian Reichel
Date: Sat Apr 05 2025 - 19:04:40 EST
Hi,
On Wed, Apr 02, 2025 at 07:45:42PM +0800, shao.mingyin@xxxxxxxxxx wrote:
> From: Zhang Enpei <zhang.enpei@xxxxxxxxxx>
>
> Replace the open-code with dev_err_probe() to simplify the code.
>
> Signed-off-by: Zhang Enpei <zhang.enpei@xxxxxxxxxx>
> Signed-off-by: Shao Mingyin <shao.mingyin@xxxxxxxxxx>
> ---
> drivers/phy/rockchip/phy-rockchip-typec.c | 8 +++-----
> 1 file changed, 3 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/phy/rockchip/phy-rockchip-typec.c b/drivers/phy/rockchip/phy-rockchip-typec.c
> index d9701b6106d5..94d1e6ead1a7 100644
> --- a/drivers/phy/rockchip/phy-rockchip-typec.c
> +++ b/drivers/phy/rockchip/phy-rockchip-typec.c
> @@ -1151,11 +1151,9 @@ static int rockchip_typec_phy_probe(struct platform_device *pdev)
> if (IS_ERR(tcphy->extcon)) {
> if (PTR_ERR(tcphy->extcon) == -ENODEV) {
> tcphy->extcon = NULL;
> - } else {
> - if (PTR_ERR(tcphy->extcon) != -EPROBE_DEFER)
> - dev_err(dev, "Invalid or missing extcon\n");
> - return PTR_ERR(tcphy->extcon);
> - }
> + } else
> + return dev_err_probe(dev, PTR_ERR(tcphy->extcon),
> + "Invalid or missing extcon\n");
You should also remove the { } for the normal if clause. Otherwise
Reviewed-by: Sebastian Reichel <sebastian.reichel@xxxxxxxxxxxxx>
But you might want to throw in an extra patch updating the error
message. -ENODEV is covered explicitly, so it's not "missing". I
suggest "Failed to get extcon".
Greetings,
-- Sebastian
> }
>
> pm_runtime_enable(dev);
> --
> 2.25.1
>
Attachment:
signature.asc
Description: PGP signature