Re: [PATCH v3 25/32] rtc: s5m: cache value of platform_get_device_id() during probe
From: Krzysztof Kozlowski
Date: Sun Apr 06 2025 - 14:30:06 EST
On 03/04/2025 10:59, André Draszik wrote:
> platform_get_device_id() is called mulitple times during probe. This
> makes the code harder to read than necessary.
>
> Just get the ID once, which also trims the lengths of the lines
> involved.
>
> Signed-off-by: André Draszik <andre.draszik@xxxxxxxxxx>
> ---
> drivers/rtc/rtc-s5m.c | 8 +++++---
> 1 file changed, 5 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/rtc/rtc-s5m.c b/drivers/rtc/rtc-s5m.c
> index db5c9b641277213aa1371776c63e2eda3f223465..53c76b0e4253a9ba225c3c723d35d9182d071607 100644
> --- a/drivers/rtc/rtc-s5m.c
> +++ b/drivers/rtc/rtc-s5m.c
> @@ -637,6 +637,8 @@ static int s5m8767_rtc_init_reg(struct s5m_rtc_info *info)
> static int s5m_rtc_probe(struct platform_device *pdev)
> {
> struct sec_pmic_dev *s5m87xx = dev_get_drvdata(pdev->dev.parent);
> + const struct platform_device_id * const id =
> + platform_get_device_id(pdev);
If doing this, why not storing here driver data, so the enum type?
Best regards,
Krzysztof