[PATCH v7 5/9] gpio: aggregator: rename 'name' to 'key' in gpio_aggregator_parse()

From: Koichiro Den
Date: Mon Apr 07 2025 - 00:32:08 EST


Rename the local variable 'name' in gpio_aggregator_parse() to 'key'
because struct gpio_aggregator_line now uses the 'name' field for the
custom line name and the local variable actually represents a 'key'.
This change prepares for the next but one commit.

No functional change.

Reviewed-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx>
Signed-off-by: Koichiro Den <koichiro.den@xxxxxxxxxxxxx>
---
drivers/gpio/gpio-aggregator.c | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/drivers/gpio/gpio-aggregator.c b/drivers/gpio/gpio-aggregator.c
index d1c837f00ffe..2d8a7019b75e 100644
--- a/drivers/gpio/gpio-aggregator.c
+++ b/drivers/gpio/gpio-aggregator.c
@@ -998,7 +998,7 @@ static struct configfs_subsystem gpio_aggregator_subsys = {
static int gpio_aggregator_parse(struct gpio_aggregator *aggr)
{
char *args = skip_spaces(aggr->args);
- char *name, *offsets, *p;
+ char *key, *offsets, *p;
unsigned int i, n = 0;
int error = 0;

@@ -1007,18 +1007,18 @@ static int gpio_aggregator_parse(struct gpio_aggregator *aggr)
if (!bitmap)
return -ENOMEM;

- args = next_arg(args, &name, &p);
+ args = next_arg(args, &key, &p);
while (*args) {
args = next_arg(args, &offsets, &p);

p = get_options(offsets, 0, &error);
if (error == 0 || *p) {
/* Named GPIO line */
- error = gpio_aggregator_add_gpio(aggr, name, U16_MAX, &n);
+ error = gpio_aggregator_add_gpio(aggr, key, U16_MAX, &n);
if (error)
return error;

- name = offsets;
+ key = offsets;
continue;
}

@@ -1030,12 +1030,12 @@ static int gpio_aggregator_parse(struct gpio_aggregator *aggr)
}

for_each_set_bit(i, bitmap, AGGREGATOR_MAX_GPIOS) {
- error = gpio_aggregator_add_gpio(aggr, name, i, &n);
+ error = gpio_aggregator_add_gpio(aggr, key, i, &n);
if (error)
return error;
}

- args = next_arg(args, &name, &p);
+ args = next_arg(args, &key, &p);
}

if (!n) {
--
2.45.2