[PATCH v2 0/2] iio: imu: inv_icm42600: switch to use generic name irq get

From: Jean-Baptiste Maneyrol via B4 Relay
Date: Mon Apr 07 2025 - 16:10:55 EST


The purpose of this series is to switch to fwnode_irq_get_by_name()
in the core module instead of using irq from the bus parsing.
Add interrupt naming and support only INT1.

Signed-off-by: Jean-Baptiste Maneyrol <jean-baptiste.maneyrol@xxxxxxx>
---
Changes in v2:
- Add INT2 in interrupt-names enum and fix enum
- Add fallback to first interrupt if naming is not here to ensure
backward compatibility
- Link to v1: https://lore.kernel.org/r/20250404-iio-imu-inv-icm42600-rework-interrupt-using-names-v1-0-72ed5100da14@xxxxxxx

---
Jean-Baptiste Maneyrol (2):
dt-bindings: iio: imu: icm42600: add interrupt naming support
iio: imu: inv_icm42600: switch to use generic name irq get

.../bindings/iio/imu/invensense,icm42600.yaml | 13 +++++++++++++
drivers/iio/imu/inv_icm42600/inv_icm42600.h | 2 +-
drivers/iio/imu/inv_icm42600/inv_icm42600_core.c | 17 +++++++++++++++--
drivers/iio/imu/inv_icm42600/inv_icm42600_i2c.c | 2 +-
drivers/iio/imu/inv_icm42600/inv_icm42600_spi.c | 2 +-
5 files changed, 31 insertions(+), 5 deletions(-)
---
base-commit: e3ee177e2a3e21ef4502f68336023154049d2acd
change-id: 20250325-iio-imu-inv-icm42600-rework-interrupt-using-names-b397ced72835

Best regards,
--
Jean-Baptiste Maneyrol <jean-baptiste.maneyrol@xxxxxxx>