Re: [RFC PATCH -next v3 04/10] nvmet: set WZDS and DRB if device supports BLK_FEAT_WRITE_ZEROES_UNMAP
From: Christoph Hellwig
Date: Wed Apr 09 2025 - 06:36:08 EST
On Tue, Mar 18, 2025 at 03:35:39PM +0800, Zhang Yi wrote:
> diff --git a/include/linux/blkdev.h b/include/linux/blkdev.h
> index 5d280c7fba65..836738ab1fa6 100644
> --- a/include/linux/blkdev.h
> +++ b/include/linux/blkdev.h
> @@ -1344,6 +1344,11 @@ static inline unsigned int bdev_write_zeroes_sectors(struct block_device *bdev)
> return bdev_limits(bdev)->max_write_zeroes_sectors;
> }
>
> +static inline bool bdev_unmap_write_zeroes(struct block_device *bdev)
> +{
> + return bdev_limits(bdev)->features & BLK_FEAT_WRITE_ZEROES_UNMAP;
This helper has an odd name. In doubt stick to the name of the flag
instead of reordering the words.
Also no core block code should be added in an nvmet patch, this needs
to go into the first patch.