Re: [PATCH v2 2/2] rust: workqueue: remove HasWork::OFFSET

From: Tamir Duberstein
Date: Thu Apr 10 2025 - 10:22:30 EST


On Thu, Apr 10, 2025 at 5:16 AM Alice Ryhl <aliceryhl@xxxxxxxxxx> wrote:
>
> On Wed, Apr 09, 2025 at 06:03:22AM -0400, Tamir Duberstein wrote:
> > Implement `HasWork::work_container_of` in `impl_has_work!`, narrowing
> > the interface of `HasWork` and replacing pointer arithmetic with
> > `container_of!`. Remove the provided implementation of
> > `HasWork::get_work_offset` without replacement; an implementation is
> > already generated in `impl_has_work!`. Remove the `Self: Sized` bound on
> > `HasWork::work_container_of` which was apparently necessary to access
> > `OFFSET` as `OFFSET` no longer exists.
> >
> > A similar API change was discussed on the hrtimer series[1].
> >
> > Link: https://lore.kernel.org/all/20250224-hrtimer-v3-v6-12-rc2-v9-1-5bd3bf0ce6cc@xxxxxxxxxx/ [1]
> > Reviewed-by: Benno Lossin <benno.lossin@xxxxxxxxx>
> > Reviewed-by: Alice Ryhl <aliceryhl@xxxxxxxxxx>
> > Tested-by: Alice Ryhl <aliceryhl@xxxxxxxxxx>
> > Signed-off-by: Tamir Duberstein <tamird@xxxxxxxxx>
> > ---
> > rust/kernel/workqueue.rs | 45 ++++++++++++---------------------------------
> > 1 file changed, 12 insertions(+), 33 deletions(-)
> >
> > diff --git a/rust/kernel/workqueue.rs b/rust/kernel/workqueue.rs
> > index f98bd02b838f..1d640dbdc6ad 100644
> > --- a/rust/kernel/workqueue.rs
> > +++ b/rust/kernel/workqueue.rs
> > @@ -429,51 +429,23 @@ pub unsafe fn raw_get(ptr: *const Self) -> *mut bindings::work_struct {
> > ///
> > /// # Safety
> > ///
> > -/// The [`OFFSET`] constant must be the offset of a field in `Self` of type [`Work<T, ID>`]. The
> > -/// methods on this trait must have exactly the behavior that the definitions given below have.
> > +/// The methods on this trait must have exactly the behavior that the definitions given below have.
>
> This wording probably needs to be rephrased. You got rid of the
> definitions that sentence refers to.

I don't follow. What definitions was it referring to? I interpreted it
as having referred to all the items: constants *and* methods.

Could you propose an alternate phrasing?