Re: [PATCH v7 0/8] Add functions for getting and setting registers related to autonomous selection in cppc_acpi

From: zhenglifeng (A)
Date: Sun Apr 13 2025 - 21:26:34 EST


On 2025/4/12 2:18, Mario Limonciello wrote:

> On 4/11/2025 4:38 AM, Lifeng Zheng wrote:
>> The patch series is organized in two parts:
>>
>>   - patch 1-6 refactor out the general CPPC register get and set functions
>>     in cppc_acpi.c
>>
>>   - patches 7-8 add functions for getting and setting values of auto_sel,
>>     energy_perf and auto_act_window in cppc_acpi.c
>>
>> Changelog:
>>
>> v7:
>>
>>   - Fix some typos
>>   - Add check of null pointer in cppc_get_reg_val(),
>>     cppc_get_auto_act_window() and cppc_get_auto_sel()
>>   - Replace ternary operator with logical expression in cppc_get_reg_val()
>>
>> v6:
>>
>>   - Remove the last patch, will resent it in the future after reaching an
>>     agreement with Sumit
>>   - split patch 3 into 2 smaller patches
>>   - Remove the printing of reg_idx in cppc_get_reg_val() and
>>     cppc_set_reg_val()
>>   - Change the logic for determing whether a register is supported in
>>     cppc_get_reg_val() and cppc_set_reg_val()
>>
>> v5:
>>
>>   - add more explanation to the commit logs and comments
>>   - change REG_OPTIONAL from bin to hex
>>   - split patch 2 into 3 smaller patches
>>   - remove CPPC_REG_VAL_READ() and CPPC_REG_VAL_WRITE() macros
>>   - move the modification part in patch 5 into a separate patch
>>   - rename the sysfs file from "energy_perf" to
>>     energy_performance_preference_val
>>
>> v4:
>>
>>   - add REG_OPTIONAL and IS_OPTIONAL_CPC_REG to judge if a cpc register is
>>     an optional one
>>   - check whether the register is optional before CPC_SUPPORTED check in
>>     cppc_get_reg_val() and cppc_set_reg_val()
>>   - check the register's type in cppc_set_reg_val()
>>   - add macros to generally implement registers getting and setting
>>     functions
>>   - move some logic codes from cppc_cpufreq.c to cppc_acpi.c
>>   - replace cppc_get_auto_sel_caps() by cppc_get_auto_sel()
>>
>> v3:
>>
>>   - change cppc_get_reg() and cppc_set_reg() name to cppc_get_reg_val() and
>>     cppc_set_reg_val()
>>   - extract cppc_get_reg_val_in_pcc() and cppc_set_reg_val_in_pcc()
>>   - return the result of cpc_read() in cppc_get_reg_val()
>>   - add pr_debug() in cppc_get_reg_val_in_pcc() when pcc_ss_id < 0
>>   - rename 'cpunum' to 'cpu' in cppc_get_reg_val()
>>   - move some macros from drivers/cpufreq/cppc_cpufreq.c to
>>     include/acpi/cppc_acpi.h with a CPPC_XXX prefix
>>
>> v2:
>>
>>   - fix some incorrect placeholder
>>   - change kstrtoul to kstrtobool in store_auto_select
>>
>> ---
>> Discussions of previous versions:
>> v1: https://lore.kernel.org/all/20241114084816.1128647-1-zhenglifeng1@xxxxxxxxxx/
>> v2: https://lore.kernel.org/all/20241122062051.3658577-1-zhenglifeng1@xxxxxxxxxx/
>> v3: https://lore.kernel.org/all/20241216091603.1247644-1-zhenglifeng1@xxxxxxxxxx/
>> v4: https://lore.kernel.org/all/20250113122104.3870673-1-zhenglifeng1@xxxxxxxxxx/
>> v5: https://lore.kernel.org/all/20250206131428.3261578-1-zhenglifeng1@xxxxxxxxxx/
>> v6: https://lore.kernel.org/all/20250409065703.1461867-1-zhenglifeng1@xxxxxxxxxx/
>>
>> Lifeng Zheng (8):
>>    ACPI: CPPC: Add IS_OPTIONAL_CPC_REG macro to judge if a cpc_reg is
>>      optional
>>    ACPI: CPPC: Optimize cppc_get_perf()
>>    ACPI: CPPC: Rename cppc_get_perf() to cppc_get_reg_val()
>>    ACPI: CPPC: Extract cppc_get_reg_val_in_pcc()
>>    ACPI: CPPC: Add cppc_set_reg_val()
>>    ACPI: CPPC: Refactor register value get and set ABIs
>>    ACPI: CPPC: Modify cppc_get_auto_sel_caps() to cppc_get_auto_sel()
>>    ACPI: CPPC: Add three functions related to autonomous selection
>>
>>   drivers/acpi/cppc_acpi.c     | 313 +++++++++++++++++++++--------------
>>   drivers/cpufreq/amd-pstate.c |   3 +-
>>   include/acpi/cppc_acpi.h     |  30 +++-
>>   3 files changed, 219 insertions(+), 127 deletions(-)
>>
>
> Reviewed-by: Mario Limonciello <mario.limonciello@xxxxxxx>

Thank you!

Regards,
Lifeng