Re: [PATCH 02/17] scsi: bfa: Rename 'timer_mod' to 'timer_module'
From: Thomas Weißschuh
Date: Mon Apr 14 2025 - 06:59:25 EST
On Mon, Apr 14, 2025 at 12:22:36PM +0200, Ingo Molnar wrote:
> We'd like to introduce timer_mod() in the kernel, so make
> sure the namespace is clear.
>
> Signed-off-by: Ingo Molnar <mingo@xxxxxxxxxx>
> Cc: Anil Gurumurthy <anil.gurumurthy@xxxxxxxxxx>
> Cc: "James E.J. Bottomley" <James.Bottomley@xxxxxxxxxxxxxxxxxxxxx>
> Cc: "Martin K. Petersen" <martin.petersen@xxxxxxxxxx>
> Cc: Sudarsana Kalluru <sudarsana.kalluru@xxxxxxxxxx>
> ---
> arch/arm/mach-omap1/pm.c | 2 +-
> arch/arm/mach-s3c/s3c64xx.c | 4 +--
> arch/arm/mach-s3c/s3c64xx.h | 6 ++---
> arch/x86/kvm/cpuid.c | 4 +--
> arch/x86/kvm/lapic.c | 18 ++++++-------
> arch/x86/kvm/lapic.h | 4 +--
> drivers/clocksource/timer-ti-32k.c | 4 +--
> drivers/clocksource/timer-ti-dm.c | 6 ++---
> drivers/comedi/drivers/addi_apci_3120.c | 20 +++++++-------
> drivers/comedi/drivers/addi_apci_3501.c | 2 +-
> drivers/counter/rz-mtu3-cnt.c | 16 +++++------
> drivers/fpga/dfl-n3000-nios.c | 20 +++++++-------
> drivers/gpu/drm/msm/msm_drv.h | 4 +--
> drivers/gpu/drm/msm/msm_io_utils.c | 4 +--
> drivers/leds/leds-netxbig.c | 4 +--
> drivers/scsi/bfa/bfa.h | 2 +-
> drivers/scsi/bfa/bfa_core.c | 4 +--
> drivers/scsi/bfa/bfa_ioc.c | 20 +++++++-------
> drivers/scsi/bfa/bfa_ioc.h | 10 +++----
> drivers/scsi/bfa/bfa_modules.h | 2 +-
> drivers/scsi/bfa/bfad.c | 2 +-
> fs/timerfd.c | 2 +-
> include/clocksource/timer-ti-dm.h | 2 +-
> include/linux/hrtimer.h | 24 ++++++++---------
> include/linux/torture.h | 2 +-
> include/trace/events/rxrpc.h | 16 +++++------
> include/trace/events/timer.h | 14 +++++-----
> io_uring/rw.c | 2 +-
> io_uring/timeout.c | 8 +++---
> io_uring/timeout.h | 2 +-
> kernel/bpf/helpers.c | 2 +-
> kernel/time/hrtimer.c | 34 ++++++++++++------------
> kernel/time/posix-timers.c | 2 +-
> kernel/time/sleep_timeout.c | 6 ++---
> kernel/torture.c | 2 +-
> net/rxrpc/ar-internal.h | 4 +--
> net/rxrpc/call_event.c | 2 +-
> net/rxrpc/input.c | 4 +--
> net/rxrpc/input_rack.c | 10 +++----
> net/rxrpc/output.c | 2 +-
> rust/kernel/time/hrtimer.rs | 32 +++++++++++-----------
> tools/testing/selftests/bpf/progs/test_vmlinux.c | 4 +--
> 42 files changed, 167 insertions(+), 167 deletions(-)
>
> diff --git a/arch/arm/mach-omap1/pm.c b/arch/arm/mach-omap1/pm.c
> index 6a5815aa05e6..ce9295ca2960 100644
> --- a/arch/arm/mach-omap1/pm.c
> +++ b/arch/arm/mach-omap1/pm.c
> @@ -118,7 +118,7 @@ void omap1_pm_idle(void)
> #endif
>
> #ifdef CONFIG_OMAP_DM_TIMER
> - use_idlect1 = omap_dm_timer_modify_idlect_mask(use_idlect1);
> + use_idlect1 = omap_dm_timer_moduleify_idlect_mask(use_idlect1);
Many changes in this patch look iffy and unnecessary.
> #endif
>
> if (omap_dma_running())
> diff --git a/arch/arm/mach-s3c/s3c64xx.c b/arch/arm/mach-s3c/s3c64xx.c
> index 6c70ea7f2931..6c1d020b181e 100644
> --- a/arch/arm/mach-s3c/s3c64xx.c
> +++ b/arch/arm/mach-s3c/s3c64xx.c
> @@ -165,8 +165,8 @@ static struct samsung_pwm_variant s3c64xx_pwm_variant = {
> .tclk_mask = (1 << 7) | (1 << 6) | (1 << 5),
> };
>
> -void __init s3c64xx_set_timer_source(enum s3c64xx_timer_mode event,
> - enum s3c64xx_timer_mode source)
> +void __init s3c64xx_set_timer_source(enum s3c64xx_timer_modulee event,
> + enum s3c64xx_timer_modulee source)
> {
> s3c64xx_pwm_variant.output_mask = BIT(SAMSUNG_PWM_NUM) - 1;
> s3c64xx_pwm_variant.output_mask &= ~(BIT(event) | BIT(source));
<snip>