Re: [PATCH] arm64: kvm: Replace ternary flags with str_on_off() helper

From: Anshuman Khandual
Date: Tue Apr 15 2025 - 02:37:10 EST




On 4/15/25 06:54, Seongsu Park wrote:
> Replace repetitive ternary expressions with the str_on_off() helper
> function. This change improves code readability and ensures consistency
> in tracepoint string formatting
>
> Signed-off-by: Seongsu Park <sgsu.park@xxxxxxxxxxx>
> ---
> arch/arm64/kvm/trace_arm.h | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/arch/arm64/kvm/trace_arm.h b/arch/arm64/kvm/trace_arm.h
> index c18c1a95831e..9c60f6465c78 100644
> --- a/arch/arm64/kvm/trace_arm.h
> +++ b/arch/arm64/kvm/trace_arm.h
> @@ -176,7 +176,7 @@ TRACE_EVENT(kvm_set_way_flush,
> ),
>
> TP_printk("S/W flush at 0x%016lx (cache %s)",
> - __entry->vcpu_pc, __entry->cache ? "on" : "off")
> + __entry->vcpu_pc, str_on_off(__entry->cache))
> );
>
> TRACE_EVENT(kvm_toggle_cache,
> @@ -196,8 +196,8 @@ TRACE_EVENT(kvm_toggle_cache,
> ),
>
> TP_printk("VM op at 0x%016lx (cache was %s, now %s)",
> - __entry->vcpu_pc, __entry->was ? "on" : "off",
> - __entry->now ? "on" : "off")
> + __entry->vcpu_pc, str_on_off(__entry->was),
> + str_on_off(__entry->now))
> );
>
> /*

Reviewed-by: Anshuman Khandual <anshuman.khandual@xxxxxxx>