Re: [PATCH v9 17/23] drm/mediatek: mtk_hdmi: Split driver and add common probe function

From: AngeloGioacchino Del Regno
Date: Tue Apr 15 2025 - 06:54:54 EST


Il 15/04/25 12:43, AngeloGioacchino Del Regno ha scritto:
In preparation for adding a new driver for the HDMI TX v2 IP,
split out the functions that will be common between the already
present mtk_hdmi (v1) driver and the new one.

Since the probe flow for both drivers is 90% similar, add a common
probe function that will be called from each driver's .probe()
callback, avoiding lots of code duplication.

Reviewed-by: CK Hu <ck.hu@xxxxxxxxxxxx>
Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@xxxxxxxxxxxxx>
---
drivers/gpu/drm/mediatek/Kconfig | 11 +-
drivers/gpu/drm/mediatek/Makefile | 1 +
drivers/gpu/drm/mediatek/mtk_hdmi.c | 538 +-----
drivers/gpu/drm/mediatek/mtk_hdmi.c.orig | 1769 ++++++++++++++++++++
drivers/gpu/drm/mediatek/mtk_hdmi_common.c | 422 +++++
drivers/gpu/drm/mediatek/mtk_hdmi_common.h | 188 +++
6 files changed, 2398 insertions(+), 531 deletions(-)
create mode 100644 drivers/gpu/drm/mediatek/mtk_hdmi.c.orig

CK, I just acknowledged that a .orig file slipped through and got sent out with
this patch....

Truly sorry for that, can you please fix that up while applying without having me
send another patchbomb?

Many thanks,
Angelo

create mode 100644 drivers/gpu/drm/mediatek/mtk_hdmi_common.c
create mode 100644 drivers/gpu/drm/mediatek/mtk_hdmi_common.h