Re: [PATCH v2 1/2] mm/rmap: rename page__anon_vma to page_anon_vma for consistency

From: David Hildenbrand
Date: Fri Apr 18 2025 - 06:40:24 EST


On 18.04.25 11:55, Ye Liu wrote:
From: Ye Liu <liuye@xxxxxxxxxx>

Renamed local variable page__anon_vma in page_address_in_vma() to
page_anon_vma. The previous naming convention of using double underscores
(__) is unnecessary and inconsistent with typical kernel style, which uses
single underscores to denote local variables. Also updated comments to
reflect the new variable name.

Functionality unchanged.

Signed-off-by: Ye Liu <liuye@xxxxxxxxxx>
---
mm/rmap.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/mm/rmap.c b/mm/rmap.c
index 67bb273dfb80..b509c226e50d 100644
--- a/mm/rmap.c
+++ b/mm/rmap.c
@@ -789,13 +789,13 @@ unsigned long page_address_in_vma(const struct folio *folio,
const struct page *page, const struct vm_area_struct *vma)
{
if (folio_test_anon(folio)) {
- struct anon_vma *page__anon_vma = folio_anon_vma(folio);
+ struct anon_vma *page_anon_vma = folio_anon_vma(folio);

I'm extremely confused why this should not simply be called "anon_vma". Why do we need the "page" in here *at all* ?

--
Cheers,

David / dhildenb