Re: [PATCH v3] mm/page_alloc: simplify lowmem_reserve max calculation
From: Andrew Morton
Date: Sat Aug 16 2025 - 03:29:07 EST
On Fri, 15 Aug 2025 10:45:09 +0800 Ye Liu <ye.liu@xxxxxxxxx> wrote:
> From: Ye Liu <liuye@xxxxxxxxxx>
>
> Use max() to find the maximum lowmem_reserve value and min_t() to
> cap it to managed_pages in calculate_totalreserve_pages(), instead
> of open-coding the comparisons. No functional change.
>
> ...
>
> --- a/mm/page_alloc.c
> +++ b/mm/page_alloc.c
> @@ -6235,16 +6235,13 @@ static void calculate_totalreserve_pages(void)
> unsigned long managed_pages = zone_managed_pages(zone);
>
> /* Find valid and maximum lowmem_reserve in the zone */
> - for (j = i; j < MAX_NR_ZONES; j++) {
> - if (zone->lowmem_reserve[j] > max)
> - max = zone->lowmem_reserve[j];
> - }
> + for (j = i; j < MAX_NR_ZONES; j++)
> + max = max(max, zone->lowmem_reserve[j]);
>
> /* we treat the high watermark as reserved pages. */
> max += high_wmark_pages(zone);
>
> - if (max > managed_pages)
> - max = managed_pages;
> + max = min_t(unsigned long, max, managed_pages);
>
Use of max_t/min_t is usually a sign that we messed up the type choices
somewhere.
In this case, I'd say that zone.lowmem_reserve[] should have been
ulong. Oh well.