Re: [PATCH v2] mm/zswap: store <PAGE_SIZE compression failed page as-is

From: Chris Li
Date: Mon Aug 18 2025 - 16:33:36 EST


On Mon, Aug 18, 2025 at 11:18 AM SeongJae Park <sj@xxxxxxxxxx> wrote:
>
> On Fri, 15 Aug 2025 19:23:10 -0700 Chris Li <chrisl@xxxxxxxxxx> wrote:
>
> > On Fri, Aug 15, 2025 at 5:14 PM SeongJae Park <sj@xxxxxxxxxx> wrote:
> > >
> > > Sounds good. So in the next version (v4), I will drop compress_fail. Instead,
> > > I will add two new counters, namely compress_engine_fail and the new atomic
> > > counter, say, stored_uncompressed_pages. Please suggest better names or
> > > correct me if I'm missing some of your points.
> >
> > Sounds great. As I suggest in my other email, if up to me,
> >
> > "crypto_compress_fail" and "stored_incompressible_pages"
>
> Nice names, thank you! I'll send the next verison soon, following all your
> suggestions[1] together.

Thanks, looking forward to it.

Chris