Re: [PATCH] PCI: keystone: Use kcalloc() instead of kzalloc()

From: Siddharth Vadapalli
Date: Tue Aug 19 2025 - 05:49:36 EST


On Tue, Aug 19, 2025 at 04:59:15PM +0800, Qianfeng Rong wrote:

Hello,

> Replace calls of devm_kzalloc() with devm_kcalloc() in ks_pcie_probe() for
> safer memory allocation with built-in overflow protection.

Please add more details by referring to:
https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
and stating that multiplication could lead to an overflow and isn't safe
when it is used to calculate the size of allocation.

>
> Signed-off-by: Qianfeng Rong <rongqianfeng@xxxxxxxx>
> ---
> drivers/pci/controller/dwc/pci-keystone.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/pci/controller/dwc/pci-keystone.c b/drivers/pci/controller/dwc/pci-keystone.c
> index 7d7aede54ed3..3d10e1112131 100644
> --- a/drivers/pci/controller/dwc/pci-keystone.c
> +++ b/drivers/pci/controller/dwc/pci-keystone.c
> @@ -1212,11 +1212,11 @@ static int ks_pcie_probe(struct platform_device *pdev)
> if (ret)
> num_lanes = 1;
>
> - phy = devm_kzalloc(dev, sizeof(*phy) * num_lanes, GFP_KERNEL);
> + phy = devm_kcalloc(dev, num_lanes, sizeof(*phy), GFP_KERNEL);
> if (!phy)
> return -ENOMEM;
>
> - link = devm_kzalloc(dev, sizeof(*link) * num_lanes, GFP_KERNEL);
> + link = devm_kcalloc(dev, num_lanes, sizeof(*link), GFP_KERNEL);
> if (!link)
> return -ENOMEM;

Regards,
Siddharth.