[PATCH] staging: iio: adc: ad7816: Use spi_set_drvdata() for clarity
From: Salah Triki
Date: Tue Aug 19 2025 - 07:41:42 EST
Replace the use of `dev_set_drvdata()` with the `spi_set_drvdata()`
helper. This is functionally identical, but improves readability.
Signed-off-by: Salah Triki <salah.triki@xxxxxxxxx>
---
drivers/staging/iio/adc/ad7816.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/iio/adc/ad7816.c b/drivers/staging/iio/adc/ad7816.c
index 4774df778de9..599f75103cb0 100644
--- a/drivers/staging/iio/adc/ad7816.c
+++ b/drivers/staging/iio/adc/ad7816.c
@@ -360,7 +360,7 @@ static int ad7816_probe(struct spi_device *spi_dev)
return -ENOMEM;
chip = iio_priv(indio_dev);
/* this is only used for device removal purposes */
- dev_set_drvdata(&spi_dev->dev, indio_dev);
+ spi_set_drvdata(spi_dev, indio_dev);
chip->spi_dev = spi_dev;
for (i = 0; i <= AD7816_CS_MAX; i++)
--
2.43.0