Re: [PATCH net] i40e: Prevent unwanted interface name changes

From: Michal Schmidt
Date: Wed Aug 20 2025 - 02:43:04 EST


On Wed, Aug 20, 2025 at 6:30 AM Calvin Owens <calvin@xxxxxxxxxx> wrote:
> The same naming regression which was reported in ixgbe and fixed in
> commit e67a0bc3ed4f ("ixgbe: prevent from unwanted interface name
> changes") still exists in i40e.
>
> Fix i40e by setting the same flag, added in commit c5ec7f49b480
> ("devlink: let driver opt out of automatic phys_port_name generation").
>
> Fixes: 9e479d64dc58 ("i40e: Add initial devlink support")

But this one's almost two years old. By now, there may be more users
relying on the new name than on the old one.
Michal