Re: [PATCH v2] RDMA/erdma: Use vcalloc() instead of vzalloc()
From: Cheng Xu
Date: Thu Aug 21 2025 - 05:28:46 EST
On 8/21/25 3:22 PM, Qianfeng Rong wrote:
> Replace vzalloc() with vcalloc() in vmalloc_to_dma_addrs(). As noted
> in the kernel documentation [1], open-coded multiplication in allocator
> arguments is discouraged because it can lead to integer overflow.
>
> Use vcalloc() to gain built-in overflow protection, making memory
> allocation safer when calculating allocation size compared to explicit
> multiplication.
>
> [1]: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Qianfeng Rong <rongqianfeng@xxxxxxxx>
> ---
> v2: change sizeof(dma_addr_t) to sizeof(*pg_dma) to improve code
> robustness as suggested by Markus.
> ---
> drivers/infiniband/hw/erdma/erdma_verbs.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
Thanks.
Reviewed-by: Cheng Xu <chengyou@xxxxxxxxxxxxxxxxx>
> diff --git a/drivers/infiniband/hw/erdma/erdma_verbs.c b/drivers/infiniband/hw/erdma/erdma_verbs.c
> index 996860f49b2f..109a3f3de911 100644
> --- a/drivers/infiniband/hw/erdma/erdma_verbs.c
> +++ b/drivers/infiniband/hw/erdma/erdma_verbs.c
> @@ -671,7 +671,7 @@ static u32 vmalloc_to_dma_addrs(struct erdma_dev *dev, dma_addr_t **dma_addrs,
>
> npages = (PAGE_ALIGN((u64)buf + len) - PAGE_ALIGN_DOWN((u64)buf)) >>
> PAGE_SHIFT;
> - pg_dma = vzalloc(npages * sizeof(dma_addr_t));
> + pg_dma = vcalloc(npages, sizeof(*pg_dma));
> if (!pg_dma)
> return 0;
>