Re: [PATCH v2 0/7] ARM: dts: clean up most ls1021a CHECK_DTB warning

From: Shawn Guo
Date: Fri Aug 22 2025 - 05:58:08 EST


On Wed, Aug 20, 2025 at 12:36:50PM -0400, Frank Li wrote:
> clean up most ls1021a CHECK_DTB warning.
>
> Old uboot check esdhc@1560000. The new uboot already switch to check both
> esdhc@1560000 and mmc@1560000. So we can rename it now.
>
> Signed-off-by: Frank Li <Frank.Li@xxxxxxx>
> ---
> Changes in v2:
> - squash rename to flash patches
> - remove duplicate patches already post in
> https://lore.kernel.org/linux-devicetree/20250725061339.266125-1-alexander.stein@xxxxxxxxxxxxxxx/
> - Link to v1: https://lore.kernel.org/r/20250818-ls1021a_dts_warning-v1-0-7a79b6b4a0e2@xxxxxxx
>
> ---
> Frank Li (7):
> ARM: dts: ls1021a: Rename node name nor to flash
> ARM: dts: ls1021a: Rename 'mdio-mux-emi1' to 'mdio-mux@54'
> ARM: dts: ls1021a: Rename esdhc@1560000 to mmc@1560000
> ARM: dts: ls1021a: Rename node name power-controler to wakeup-controller
> ARM: dts: ls1021a: remove big-endian for mmc modes
> ARM: dts: ls1021a-tsn: Remove redundant #address-cells for ethernet-switch@1
> ARM: dts: ls1021a-tqmls1021a-mbls1021a-rgb-cdtech: Remove fallback compatible string edt,edt-ft5x06

Frank,

Could you rebase on imx/dt branch?

Shawn