Re: [PATCH 1/3] KVM: x86: Rename supports_cpuid_fault to supports_intel_cpuid_fault
From: Jim Mattson
Date: Fri Apr 10 2026 - 18:22:52 EST
On Fri, Apr 10, 2026 at 3:21 PM Sean Christopherson <seanjc@xxxxxxxxxx> wrote:
>
> On Thu, Apr 02, 2026, Jim Mattson wrote:
> > The function, supports_cpuid_fault(), tests for guest support of Intel's
> > CPUID faulting feature. Rename the function to supports_intel_cpuid_fault()
> > for clarity.
> >
> > Signed-off-by: Jim Mattson <jmattson@xxxxxxxxxx>
> > ---
> > arch/x86/kvm/cpuid.h | 2 +-
> > arch/x86/kvm/x86.c | 2 +-
> > 2 files changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/arch/x86/kvm/cpuid.h b/arch/x86/kvm/cpuid.h
> > index 039b8e6f40ba..51cbe67c992a 100644
> > --- a/arch/x86/kvm/cpuid.h
> > +++ b/arch/x86/kvm/cpuid.h
> > @@ -181,7 +181,7 @@ static inline int guest_cpuid_stepping(struct kvm_vcpu *vcpu)
> > return x86_stepping(best->eax);
> > }
> >
> > -static inline bool supports_cpuid_fault(struct kvm_vcpu *vcpu)
> > +static inline bool supports_intel_cpuid_fault(struct kvm_vcpu *vcpu)
>
> *sigh*
>
> I was going to suggest supports_misc_enables_cpuid_fault(), since KVM emulates
> the MSR for all CPU vendors, but the enable is in MISC_FEATURE_ENABLES, not
> IA32_MISC_ENABLES.
>
> What if we just drop the helper? There's only one user. I.e.
My thoughts exactly. :)