Re: [PATCH] iio: dac: ad3552r: use field_get() for power-down bit read
From: Piyush Patle
Date: Sun Apr 19 2026 - 12:58:15 EST
On Sat, Apr 11, 2026 at 7:18 PM Nuno Sá <noname.nuno@xxxxxxxxx> wrote:
>
> On Sat, 2026-04-11 at 10:46 +0530, Piyush Patle wrote:
> > Use field_get() for the per-channel DAC power-down bit instead of an
> > open-coded mask-and-shift sequence.
> >
> > No functional change.
> >
> > Signed-off-by: Piyush Patle <piyushpatle228@xxxxxxxxx>
> > ---
>
> Reviewed-by: Nuno Sá <nuno.sa@xxxxxxxxxx>
>
> > drivers/iio/dac/ad3552r.c | 3 +--
> > 1 file changed, 1 insertion(+), 2 deletions(-)
> >
> > diff --git a/drivers/iio/dac/ad3552r.c b/drivers/iio/dac/ad3552r.c
> > index 93c33bc3e1be..f206bba3a701 100644
> > --- a/drivers/iio/dac/ad3552r.c
> > +++ b/drivers/iio/dac/ad3552r.c
> > @@ -167,8 +167,7 @@ static int ad3552r_read_raw(struct iio_dev *indio_dev,
> > mutex_unlock(&dac->lock);
> > if (err < 0)
> > return err;
> > - *val = !((tmp_val & AD3552R_MASK_CH_DAC_POWERDOWN(ch)) >>
> > - __ffs(AD3552R_MASK_CH_DAC_POWERDOWN(ch)));
> > + *val = !field_get(AD3552R_MASK_CH_DAC_POWERDOWN(ch), tmp_val);
> > return IIO_VAL_INT;
> > case IIO_CHAN_INFO_SCALE:
> > *val = dac->ch_data[ch].scale_int;
Hi,
Gentle ping on this patch.
I’d appreciate any feedback whenever you get time, or let me know if I
should resend/rework anything.
Regards,
Piyush