Re: [PATCH] staging: media: atomisp: consolidate function declarations

From: Andy Shevchenko

Date: Mon May 04 2026 - 10:34:16 EST


On Sun, May 03, 2026 at 11:08:46PM +0530, Shyam Sunder Reddy Padira wrote:
> Consolidate split function declarations into a single
> lines to fix checkpatch.pl warnings and improve code
> readability.This change aligns with the kernel coding
> style.

Too condensed text. We have room for ~72 character per line.

> No functional changes.

...

> -const struct
> -atomisp_format_bridge *atomisp_get_format_bridge(unsigned int pixelformat);
> +const struct atomisp_format_bridge *atomisp_get_format_bridge(unsigned int pixelformat);
>
> -const struct
> -atomisp_format_bridge *atomisp_get_format_bridge_from_mbus(u32 mbus_code);
> +const struct atomisp_format_bridge *atomisp_get_format_bridge_from_mbus(u32 mbus_code);

It breaks V4L2 coding style expectations.

NAK.

Also other problems mentioned many times in the mailing list. Please, start
reviewing others' patches and learn from other reviews before doing your
changes.

--
With Best Regards,
Andy Shevchenko