Re: [PATCH] leds: Move MODULE_DEVICE_TABLE next to the table itself
From: Thomas Weißschuh
Date: Wed May 06 2026 - 02:20:19 EST
On 2026-05-05 12:28:45+0200, Krzysztof Kozlowski wrote:
> By convention MODULE_DEVICE_TABLE() immediately follows the ID table it
> exports, because this is easier to read and verify. It also makes more
> sense since #ifdef for ACPI or OF could hide both of them.
>
> Most of the privers already have this correctly placed, so adjust
> the missing ones. No functional impact.
>
> Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@xxxxxxxxxxxxxxxx>
Acked-by: Thomas Weißschuh <linux@xxxxxxxxxxxxxx> # leds-cros_ec.c
> ---
> drivers/leds/blink/leds-bcm63138.c | 2 +-
> drivers/leds/leds-cros_ec.c | 2 +-
> 2 files changed, 2 insertions(+), 2 deletions(-)
(...)