Re: [PATCH v1] drm/bridge: analogix_dp: Convert status check functions to bool

From: Luca Ceresoli

Date: Thu May 21 2026 - 15:58:06 EST


On Thu May 21, 2026 at 12:27 PM CEST, Damon Ding wrote:
> Convert analogix_dp_is_slave_video_stream_clock_on() and
> analogix_dp_is_video_stream_on() from int to bool return type.
>
> This makes the code more readable and aligns with kernel best
> practices for boolean status checks, while simplifying the
> callers by removing unnecessary "== 0" comparisons.
>
> Signed-off-by: Damon Ding <damon.ding@xxxxxxxxxxxxxx>

Reviewed-by: Luca Ceresoli <luca.ceresoli@xxxxxxxxxxx>

--
Luca Ceresoli, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com