Re: [PATCH] crypto: amcc - convert irq_of_parse_and_map to platform_get_irq

From: Herbert Xu

Date: Thu Jun 11 2026 - 04:56:01 EST


On Mon, Jun 01, 2026 at 06:46:45PM -0700, Rosen Penev wrote:
> Replace the deprecated irq_of_parse_and_map() call with the modern
> platform_get_irq() in the probe function. This also improves error
> handling: platform_get_irq() returns a negative errno on failure,
> whereas irq_of_parse_and_map() returned 0.
>
> Change the irq field in struct crypto4xx_core_device from u32 to int
> to match the return type of platform_get_irq().
>
> Assisted-by: opencode:big-pickle
> Signed-off-by: Rosen Penev <rosenp@xxxxxxxxx>
> ---
> drivers/crypto/amcc/crypto4xx_core.c | 6 +++++-
> drivers/crypto/amcc/crypto4xx_core.h | 2 +-
> 2 files changed, 6 insertions(+), 2 deletions(-)

Patch applied. Thanks.
--
Email: Herbert Xu <herbert@xxxxxxxxxxxxxxxxxxx>
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt