Re: [v2 06/16] mm: rename ARCH_ENABLE_THP_MIGRATION to ARCH_SUPPORTS_PMD_SOFTLEAF

From: Zi Yan

Date: Sat Jun 13 2026 - 15:26:28 EST


On 2 Jun 2026, at 10:24, Usama Arif wrote:

> CONFIG_ARCH_ENABLE_THP_MIGRATION started life gating just PMD-level
> migration entries, but has grown to gate the entire PMD-level softleaf
> machinery: migration entries, device-private entries, and soon swap
> entries.
>
> Rename CONFIG_ARCH_ENABLE_THP_MIGRATION to CONFIG_ARCH_SUPPORTS_PMD
> _SOFTLEAF to make this clear. This is a pure rename: the set of
> selecting architectures (x86, arm64, s390, riscv, loongarch, and
> powerpc on PPC_BOOK3S_64) and the gating semantics are unchanged.
>
> No functional change intended.
>
> Signed-off-by: Usama Arif <usama.arif@xxxxxxxxx>
> ---
> arch/arm64/Kconfig | 2 +-
> arch/arm64/include/asm/pgtable.h | 4 ++--
> arch/loongarch/Kconfig | 2 +-
> arch/powerpc/include/asm/book3s/64/pgtable.h | 2 +-
> arch/powerpc/platforms/Kconfig.cputype | 2 +-
> arch/riscv/Kconfig | 2 +-
> arch/riscv/include/asm/pgtable.h | 8 ++++----
> arch/s390/Kconfig | 2 +-
> arch/s390/include/asm/pgtable.h | 2 +-
> arch/x86/Kconfig | 2 +-
> arch/x86/include/asm/pgtable.h | 2 +-
> include/linux/huge_mm.h | 2 +-
> include/linux/leafops.h | 8 ++++----
> include/linux/pgtable.h | 2 +-
> include/linux/swapops.h | 6 +++---
> mm/Kconfig | 2 +-
> mm/debug_vm_pgtable.c | 8 ++++----
> mm/hmm.c | 4 ++--
> mm/huge_memory.c | 2 +-
> mm/migrate.c | 4 ++--
> mm/migrate_device.c | 6 +++---
> mm/rmap.c | 2 +-
> 22 files changed, 38 insertions(+), 38 deletions(-)
>
Makes sense to me.

Acked-by: Zi Yan <ziy@xxxxxxxxxx>

--
Best Regards,
Yan, Zi