Re: [PATCH 04/20] ASoC: Intel: avs: probes: Use guard() for spin locks

From: Bui Duc Phuc

Date: Tue Jun 16 2026 - 22:47:41 EST


Hi,

I see your point.

> 3. leave guard() as is. As I mentioned, guard() carries no readability
> cost what cannot be said about its scoped_guard() friend.

Personally, I find it a bit inconsistent when guard()-based locking
and the traditional lock/unlock style are mixed within the same driver
or file.
Once I'm familiar with the syntax, I find scoped_guard() reasonably
readable as well.

That said, this is Intel ASoC code and you're maintaining this area,
so I'm happy to follow your preferred approach for v2.

Best regards,
Phuc