Re: [PATCH] spi: rpc-if: Use correct device for hardware reinitialization on resume
From: Geert Uytterhoeven
Date: Thu Jun 18 2026 - 04:31:50 EST
On Thu, 18 Jun 2026 at 10:19, Biju <biju.das.au@xxxxxxxxx> wrote:
> From: Quang Nguyen <quang.nguyen.wx@xxxxxxxxxxx>
>
> rpcif_spi_resume() currently passes the SPI controller device to
> rpcif_hw_init(), but the function should be called with the RPC
> interface device.
>
> Retrieve the rpcif private data from the SPI controller and pass
> rpc->dev instead. Also propagate the return value of rpcif_hw_init() so
> that a failure during resume is properly reported rather than silently
> ignored.
>
> Fixes: ad4728740bd6 ("spi: rpc-if: Add resume support for RZ/G3E")
> Signed-off-by: Quang Nguyen <quang.nguyen.wx@xxxxxxxxxxx>
> Signed-off-by: Biju Das <biju.das.jz@xxxxxxxxxxxxxx>
Reviewed-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx>
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds