Re: [PATCH 1/3] rust: sync: Add abstraction for synchronize_rcu()
From: Philipp Stanner
Date: Thu Jun 18 2026 - 08:48:24 EST
On Thu, 2026-06-18 at 11:47 +0000, Alice Ryhl wrote:
> On Thu, Jun 18, 2026 at 01:40:05PM +0200, Philipp Stanner wrote:
> > Moreover, this would be an opportunity to change the naming convention
> > to rcu::synchronize()
> >
> > But since Boqun & Alice are pushing for rcu::RcuKBox for the reason
> > that it seems desirable to explicitly highlight that that's a special
> > Box, I guess we should be consistent with that and also have "rcu" in
> > the name here.
>
> I prefer the naming of synchronize_rcu() here.
We might be tempted to at least call it rcu_synchronize(), though. It's
also RcuKBox, not KBoxRcu.
But I don't have hard emotions on that topic.
P.
>
> Alice