Re: [PATCH v4 3/6] x86/resctrl: Rename prev_msr to prev_mon_val
From: Reinette Chatre
Date: Thu Jun 18 2026 - 19:39:18 EST
Hi Chenyu,
On 6/13/26 12:57 AM, Chen Yu wrote:
> Rename the prev_msr field in struct arch_mbm_state to prev_mon_val.
This change as described seems out of place when considering the following
from cover letter:
This patch set focuses on the first part: enabling MMIO-based access for
Cache Monitoring Technology (CMT), *while CAT/MBM/MBA are still using MSR*.
It is thus confusing to find a change related to switching MBM to use MSR
in a series that claims that it does not do this.
The patch looks fine but reading the changelog and the first few hunks makes
this patch look out of place. Could you please update the changelog to be
accurate about what this patch does?
> With ERDT, the previous monitor value may come from an MMIO
> register rather than from an MSR, so the "msr" suffix is no longer
> accurate. The new name describes the field by its meaning (the
> previous monitor value) instead of by the access method.
>
> This is preparation for ERDT support, which reads monitoring
> counters via MMIO.
>
> No functional change.
>
Reinette