[GIT PULL] firewire updates for v7.2

From: Takashi Sakamoto

Date: Sat Jun 20 2026 - 04:11:00 EST


The following changes since commit 254f49634ee16a731174d2ae34bc50bd5f45e731:

Linux 7.1-rc1 (2026-04-26 14:19:00 -0700)

are available in the Git repository at:

git://git.kernel.org/pub/scm/linux/kernel/git/ieee1394/linux1394.git tags/firewire-updates-7.2

for you to fetch changes up to e954726de56963754c8ac9d9e76b3f59d12fef17:

firewire: core: Open-code topology list walk (2026-06-13 11:10:23 +0900)

----------------------------------------------------------------
firewire updates for v7.2

This update includes the following changes.

Unit drivers have been able to assign an arbitrary value in the mod_device
entry, which is typed as kernel_ulong_t. While storing the pointer value
is legitimate, conversion back to a pointer has been performed without
preserving const qualifier. Uwe Kleine-König introduced an union to
provide safer and more robust conversions, as part of the ongoing CHERI
enhancement work for ARM and RISC-V architectures. This update includes
changes in the sound subsystem, since the conversion pattern is widely
used in ALSA firewire stack.

The userspace applications can request the core function to perform
isochronous resource management procedures. Dingsoul reported
reference-count leak when these procedures are processed in workqueue
contexts. This update refactors the relevant code paths following a divide
and conquer approach. Consequently, it became clear that the issue still
remain only in the path when userspace applications delegate automatic
resource reallocation after bus resets to the core. In practice, the leak
is rarely triggered, and a complete fix is still in progress.

----------------------------------------------------------------
Kaitao Cheng (1):
firewire: core: Open-code topology list walk

Takashi Sakamoto (14):
firewire: core: code refactoring for early return at client resource allocation
firewire: core: code refactoring to queue work item for iso_resource
firewire: core: code refactoring for helper function to fill iso_resource parameters
firewire: core: split functions for iso_resource once operation
firewire: core: code cleanup to remove old implementations for once operation
firewire: core: append _auto suffix for non-once iso resource operations
firewire: core: code cleanup for iso resource auto creation
firewire: core: reduce critical section duration in pre-processing of isoc resource management in cdev
firewire: core: use switch statement for post-processing of isoc resource management in cdev
firewire: core: refactor notification type determination after isoc resource management in cdev
firewire: core: move allocation/reallocation paths into specific branch after isoc resource management in cdev
firewire: core: minor code refactoring for case-dependent parameters of iso resources management
firewire: core: rename member name for channel mask of isoc resource
firewire: core: cancel using delayed work for iso_resource_once management

Uwe Kleine-König (The Capable Hub) (2):
firewire: Simplify storing pointers in device id struct
ALSA: firewire: Make use of ieee1394's .driver_data_ptr

drivers/firewire/core-cdev.c | 361 ++++++++++++++++++++++++---------------
drivers/firewire/core-topology.c | 4 +-
include/linux/mod_devicetable.h | 5 +-
sound/firewire/dice/dice.c | 34 ++--
sound/firewire/fireface/ff.c | 12 +-
sound/firewire/motu/motu.c | 6 +-
sound/firewire/oxfw/oxfw.c | 4 +-
7 files changed, 254 insertions(+), 172 deletions(-)