Re: [PATCH v1] tee: qcomtee: Drop unused assignment of platform_device_id driver data

From: Amirreza Zarrabi

Date: Tue Jun 23 2026 - 23:40:14 EST


Hi,

On 6/17/2026 12:38 AM, Uwe Kleine-König (The Capable Hub) wrote:
> The driver explicitly sets the .driver_data member of struct
> platform_device_id to zero without relying on that value. Drop this
> unused assignment.
>
> While touching this array unify spacing and usage of commas and use
> a named initializer for .name for improved readability.
>
> Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@xxxxxxxxxxxx>
> ---
> Hello,
>
> while this is a cleanup that can stand on its own, it is also a
> preparation for a change to struct platform_device_id that requires that
> .driver_data isn't assigned by a list initializer.
>
> Best regards
> Uwe
>
> drivers/tee/qcomtee/call.c | 7 ++++++-
> 1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/tee/qcomtee/call.c b/drivers/tee/qcomtee/call.c
> index 0efc5646242a..4a597eeaf174 100644
> --- a/drivers/tee/qcomtee/call.c
> +++ b/drivers/tee/qcomtee/call.c
> @@ -798,7 +798,12 @@ static void qcomtee_remove(struct platform_device *pdev)
> kfree(qcomtee);
> }
>
> -static const struct platform_device_id qcomtee_ids[] = { { "qcomtee", 0 }, {} };
> +static const struct platform_device_id qcomtee_ids[] = {
> + {
> + .name = "qcomtee",
> + },
> + { }
> +};
> MODULE_DEVICE_TABLE(platform, qcomtee_ids);
>

Looks good to me, thanks.

Reviewed-by: Amirreza Zarrabi <amirreza.zarrabi@xxxxxxxxxxxxxxxx>

> static struct platform_driver qcomtee_platform_driver = {
>
> base-commit: 8d6dbbbe3ba62de0a63e962ee004afb848c8e3ac