Re: [PATCH v4 00/30] KVM: x86: x86.{c,h} spring cleaning
From: Paolo Bonzini
Date: Wed Jun 24 2026 - 08:32:25 EST
On 6/13/26 02:02, Sean Christopherson wrote:
It's still technically spring!
Perform spring cleaning on x86.{c,h} and asm/kvm_host.h, by adding regs.c
(the kvm_cache_regs.h => regs.h is already applied) and msrs.{c,h}, and moving
relevant code out of x86.c.
Rebased and applied to kvm/queue, with the following changes:
- Collect more tags
- Move enum kvm_apicv_inhibit to x86.h
- Move TSS constants to tss.h, include it in vmx.c
- Rename kvm_x86_vcpu_ioctl_get_sregs2 to kvm_vcpu_ioctl_x86_get_sregs2
- Rename kvm_x86_vcpu_ioctl_set_sregs2 to kvm_vcpu_ioctl_x86_set_sregs2
- Fix conflicts
- Changed srcu_dereference_check() to __force cast (see 18/30)
- Adjust commit message on patches 11 and 26
Paolo