Re: [PATCH v2] kdb: unify CMD_BUFLEN definition into kdb_private.h

From: Daniel Thompson

Date: Thu Jun 25 2026 - 08:53:48 EST


On Wed, Jun 17, 2026 at 07:58:20AM +0530, Naveen Kumar Chaudhary wrote:
> CMD_BUFLEN was defined separately in kdb_io.c (256) and kdb_main.c
> (200), causing kdb_main.c to use the wrong size when formatting the
> prompt string into kdb_prompt_str (which is 256 bytes).
>
> Move CMD_BUFLEN (256) into kdb_private.h so all users share a single
> consistent definition, and remove the local definitions from both
> files.
>
> Fixes: 5d5314d6795f ("kdb: core for kgdb back end (1 of 2)")
> Signed-off-by: Naveen Kumar Chaudhary <naveen.osdev@xxxxxxxxx>

Thanks for this patch.

Just wanted to let you know that I've applied this patch (and your others)
locally. However, since I have to update the test suite to match the
changes to CMD_BUFLEN, I'm afraid they won't make the cut for v7.2
(since the merge window is about to close)!


Daniel.