Fixed tag magic: was: Re: [PATCH v2 1/4] sys_info: add helper for callers that handle all_bt
From: Petr Mladek
Date: Thu Jun 25 2026 - 11:30:31 EST
On Wed 2026-06-24 13:34:19, Andrew Morton wrote:
> On Tue, 23 Jun 2026 15:34:58 +0000 Bradley Morgan <include@xxxxxxxxx> wrote:
>
> > Some callers handle SYS_INFO_ALL_BT themselves before calling sys_info().
> > Add a helper that strips that bit without turning an all_bt only mask into
> > a kernel_sys_info fallback.
>
> I assume this patch wants a Fixes: and a cc:stable also.
>
> It would be nice to have the conventional [0/N] cover letter to tell
> readers what this is all about.
>
> The patches all have different Fixes: targets. This risks inviting the
> -stable maintainers to merge only some of the patches into some
> kernels, resulting in an untested combination and which might break
> things.
I do not agree here. The Fixes tag should should point to a commit
which introduced the regression into the given code. And finding
some magic common point beause there is some magic undocumented
process for maintaining stable kernels sounds like a way to hell
to me.
Best Regards,
Petr