Re: [PATCH v4 1/7] rust: types: rename ForLt to CovariantForLt
From: Miguel Ojeda
Date: Sat Jun 27 2026 - 06:59:54 EST
On Fri, Jun 26, 2026 at 8:36 PM Danilo Krummrich <dakr@xxxxxxxxxx> wrote:
>
> Rename ForLt to CovariantForLt to prepare for the introduction of a new
> ForLt base trait that does not require covariance.
>
> The existing ForLt trait requires covariance, which enables the safe
> cast_ref() method. This rename preserves the same semantics under a more
> precise name, making room for a weaker ForLt trait in a subsequent
> commit.
>
> No functional change.
>
> Reviewed-by: Alexandre Courbot <acourbot@xxxxxxxxxx>
> Reviewed-by: Gary Guo <gary@xxxxxxxxxxx>
> Signed-off-by: Danilo Krummrich <dakr@xxxxxxxxxx>
I don't see anyone else in linux-next using it, so this is likely fine
-- if we expect others this cycle, they may need a merge.
Acked-by: Miguel Ojeda <ojeda@xxxxxxxxxx>
Cheers,
Miguel