[PATCH v6 00/17] pinctrl: airoha: split on shared and SoC drivers, add more SoCs
From: Mikhail Kshevetskiy
Date: Sun Jun 28 2026 - 10:38:09 EST
This patchset
* fixes more airoha pinctrl issues
* split combined driver on common code and several SoC specific drivers
* improves an7583 pinctrl support
* adds support of en7523 SoC
* adds support of an7563 SoC
The driver split changes are based on Matheus Sampaio Queiroga work.
Changes v2:
* more issues of airoha pinctrl driver was fixed
* SoC specific register addresses, bitfields, macroses were
removed from common header and placed to SoC specific file
* fixed address of LAN LED mappings registers for en7523 SoC
* improves support of an7583 pinctrl
Changes v3:
* improve searching of chip scu regmap necessary for drivers
operations
Changes v4:
* an7583: add support of OLT pin function
* an7581: do a proper fix of pcie_reset pins mux/conf.
Changes v5:
* improve description of an7583 i2c pinmux fix
* rename an7583 registers to match its an7583 names
* add support of an7563 SoC
Changes v6:
* fix some of the issues found by
https://sashiko.dev/#/patchset/20260622113046.3619139-1-mikhail.kshevetskiy%40iopsys.eu
* update device tree binding
* add bindings for en7523 and an7563
Mikhail Kshevetskiy (17):
dt-bindings: pinctrl: airoha: update/fix device tree binding schemas
pinctrl: airoha: an7581: fix misprint in bitfield name
pinctrl: airoha: an7583: fix I2C0_SDA_PD register bit order
pinctrl: airoha: an7583: there is no mux to enable the second i2c bus
pinctrl: airoha: an7581: fix mux/conf of pcie_reset pins
pinctrl: airoha: an7583: fix muxing of non-gpio default pins
pinctrl: airoha: move common definitions to the separate header
pinctrl: airoha: split driver on shared code and SoC specific drivers
pinctrl: airoha: an7581: remove en7581 prefix from variable names
pinctrl: airoha: an7583: remove an7583 prefix from variable names and
definitions
pinctrl: airoha: an7583: rename registers to match its an7583 names
pinctrl: airoha: an7583: add support for npu_uart pinmux
pinctrl: airoha: an7583: add support for pon_alt pinmux
pinctrl: airoha: an7583: add support for olt pinmux
pinctrl: airoha: add support of en7523 SoC
pinctrl: airoha: try to find chip scu node by phandle first
pinctrl: airoha: add support of an7563 SoC
.../pinctrl/airoha,an7563-pinctrl.yaml | 348 +++
.../pinctrl/airoha,an7583-pinctrl.yaml | 65 +-
.../pinctrl/airoha,en7523-pinctrl.yaml | 375 +++
.../pinctrl/airoha,en7581-pinctrl.yaml | 15 +-
drivers/pinctrl/airoha/Kconfig | 30 +-
drivers/pinctrl/airoha/Makefile | 7 +
drivers/pinctrl/airoha/airoha-common.h | 171 ++
drivers/pinctrl/airoha/pinctrl-airoha.c | 2455 +----------------
drivers/pinctrl/airoha/pinctrl-an7563.c | 1115 ++++++++
drivers/pinctrl/airoha/pinctrl-an7581.c | 1487 ++++++++++
drivers/pinctrl/airoha/pinctrl-an7583.c | 1497 ++++++++++
drivers/pinctrl/airoha/pinctrl-en7523.c | 1125 ++++++++
12 files changed, 6250 insertions(+), 2440 deletions(-)
create mode 100644 Documentation/devicetree/bindings/pinctrl/airoha,an7563-pinctrl.yaml
create mode 100644 Documentation/devicetree/bindings/pinctrl/airoha,en7523-pinctrl.yaml
create mode 100644 drivers/pinctrl/airoha/airoha-common.h
create mode 100644 drivers/pinctrl/airoha/pinctrl-an7563.c
create mode 100644 drivers/pinctrl/airoha/pinctrl-an7581.c
create mode 100644 drivers/pinctrl/airoha/pinctrl-an7583.c
create mode 100644 drivers/pinctrl/airoha/pinctrl-en7523.c
--
2.53.0