Re: [PATCH v4 0/3] mm: clean up folio LRU and swap declarations
From: Andrew Morton
Date: Sun Jun 28 2026 - 17:03:37 EST
On Wed, 03 Jun 2026 21:05:31 +0800 Jianyue Wu <wujianyue000@xxxxxxxxx> wrote:
> The previous version moved the folio LRU helpers out of mm/swap.c in
> one step. Based on review feedback from Johannes, Baoquan and Barry,
> split the cleanup into smaller steps:
>
> - move the page-cluster sysctl next to swap readahead in mm/swap_state.c
> - rename mm/swap.c to mm/folio_lru.c after the swap-specific bits move out
> - move MM-internal reclaim declarations out of include/linux/swap.h
>
> After this series, swap cache and swap-in readahead stay in mm/swap_state.c,
> folio LRU helpers live in mm/folio_lru.c, and MM-internal reclaim/workingset
> declarations move from include/linux/swap.h to mm/internal.h (public LRU
> helpers used outside mm/ remain in swap.h).
>
> The first patch handles the swap-specific page-cluster state before the
> file rename, so the rename commit only carries folio LRU code. The last
> patch keeps the LRU helpers used outside mm/ in include/linux/swap.h and
> moves the internal reclaim/workingset declarations to mm/internal.h.
>
> This series is based on Christoph Hellwig's swap_ops series, which
> moves swap I/O dispatch behind swap_ops and leaves mm/swap.c with less
> swap-specific state. That makes the folio LRU cleanup more natural to
> split out on top.
Patchset looks good and is well-reviewed (thanks, all).
But it's a little old and Sashiko was unable to apply it and I'm seeing
at least one (probably trivial) reject.
So please can you refresh, retest, gather the ack/review tags and
resend?
Thanks.