Re: [PATCH v5 2/3] mm: rename swap.c to folio_lru.c

From: Jianyue Wu

Date: Mon Jun 29 2026 - 21:24:04 EST


On Tue, Jun 30, 2026 at 9:12 AM Matthew Wilcox <willy@xxxxxxxxxxxxx> wrote:
>
> On Tue, Jun 30, 2026 at 09:08:18AM +0800, Jianyue Wu wrote:
> > Rename mm/swap.c to mm/folio_lru.c so the filename better matches
> > the code's main responsibility.
>
> I said I didn't want this. Rename it to folio.c instead, and then we
> can move some other things there too.

Thanks Matthew. Will rename it to mm/folio.c in v6.

Best regards,
Jianyue Wu