Re: [PATCH] ata: sata_dwc_460ex: use platform_get_irq()

From: Niklas Cassel

Date: Tue Jun 30 2026 - 04:30:49 EST


On 30 June 2026 10:21:58 CEST, Damien Le Moal <dlemoal@xxxxxxxxxx> wrote:
>On 6/30/26 16:41, Niklas Cassel wrote:
>> On Sun, Jun 28, 2026 at 04:03:10PM -0700, Rosen Penev wrote:
>>> Replace irq_of_parse_and_map() with platform_get_irq() in both
>>> sata_dwc_dma_init_old() and sata_dwc_probe(). This is the preferred
>>> way to obtain IRQs for platform devices and provides better error
>>> reporting. Remove the now-unnecessary #include <linux/of_irq.h>.
>>>
>>> irq_of_parse_and_map() requires irq_dispose_mapping(), which is missing.
>>>
>>> Assisted-by: opencode:big-pickle
>>> Signed-off-by: Rosen Penev <rosenp@xxxxxxxxx>
>>> ---
>>> drivers/ata/sata_dwc_460ex.c | 18 ++++++------------
>>> 1 file changed, 6 insertions(+), 12 deletions(-)
>>>
>>> diff --git a/drivers/ata/sata_dwc_460ex.c b/drivers/ata/sata_dwc_460ex.c
>>> index 4fc22ce4bd9a..35aa7f9acdf7 100644
>>> --- a/drivers/ata/sata_dwc_460ex.c
>>> +++ b/drivers/ata/sata_dwc_460ex.c
>>> @@ -19,7 +19,6 @@
>>> #include <linux/device.h>
>>> #include <linux/dmaengine.h>
>>> #include <linux/of.h>
>>> -#include <linux/of_irq.h>
>>> #include <linux/platform_device.h>
>>> #include <linux/phy/phy.h>
>>> #include <linux/libata.h>
>>> @@ -226,7 +225,6 @@ static int sata_dwc_dma_init_old(struct platform_device *pdev,
>>> struct sata_dwc_device *hsdev)
>>> {
>>> struct device *dev = &pdev->dev;
>>> - struct device_node *np = dev->of_node;
>>
>> While this patch drops 'struct device_node *np = dev->of_node;' from
>> sata_dwc_dma_init_old() ...
>>
>>>
>>> hsdev->dma = devm_kzalloc(dev, sizeof(*hsdev->dma), GFP_KERNEL);
>>> if (!hsdev->dma)
>>> @@ -236,11 +234,9 @@ static int sata_dwc_dma_init_old(struct platform_device *pdev,
>>> hsdev->dma->id = pdev->id;
>>>
>>> /* Get SATA DMA interrupt number */
>>> - hsdev->dma->irq = irq_of_parse_and_map(np, 1);
>>> - if (!hsdev->dma->irq) {
>>> - dev_err(dev, "no SATA DMA irq\n");
>>> - return -ENODEV;
>>> - }
>>> + hsdev->dma->irq = platform_get_irq(pdev, 1);
>>> + if (hsdev->dma->irq < 0)
>>> + return hsdev->dma->irq;
>>>
>>> /* Get physical SATA DMA register base address */
>>> hsdev->dma->regs = devm_platform_ioremap_resource(pdev, 1);
>>> @@ -1173,11 +1169,9 @@ static int sata_dwc_probe(struct platform_device *ofdev)
>>
>> it seems like you forgot to do the same for sata_dwc_probe().
>>
>> Which results in a new warning:
>> https://lore.kernel.org/oe-kbuild-all/202606301243.9MrXM4WY-lkp@xxxxxxxxx/T/#u
>>
>> Damien, perhaps drop this patch and wait for a v2,
>> or fixup the patch to remove 'struct device_node *np = dev->of_node;'
>> also from sata_dwc_probe().
>>
>>
>>> sata_dwc_enable_interrupts(hsdev);
>>>
>>> /* Get SATA interrupt number */
>>> - irq = irq_of_parse_and_map(np, 0);
>>> - if (!irq) {
>>> - dev_err(dev, "no SATA DMA irq\n");
>>> - return -ENODEV;
>>> - }
>>> + irq = platform_get_irq(ofdev, 0);
>>> + if (irq < 0)
>>> + return irq;
>>>
>>> #ifdef CONFIG_SATA_DWC_OLD_DMA
>>> if (!of_property_present(np, "dmas")) {
>
>Hmmm... np is used here though...

Inside ifdef, that is probably why Sashiko did not catch this new warning.

Rosen, I suggest that you use dev->of_node directly within the ifdef, and drop the local np variable.


Kind regards,
Niklas